VisuALG #5 – Desvio condicional composto (SE… ENTÃO… SENÃO… FIMSE)

Publicado: maio 18, 2014 em Introdução à Ciência da Computação
Tags:, ,

VisuALG

SE… ENTÃO… SENÃO… FIMSE

O desvio condicional composto (SE… ENTÃO… SENÃO… FIMSE) funciona exatamente como o desvio condicional simples (SE… ENTÃO… FIMSE), com apenas uma diferença. No desvio condicional simples, somente podemos executar comandos SE a CONDIÇÃO for VERDADEIRA.

No desvio condicional composto, os comandos sempre serão executados independente da CONDIÇÃO, ou seja, SE a CONDIÇÃO for VERDADEIRA os COMANDOS DA CONDIÇÃO VERDADEIRA serão executados, SENÃO (SE a CONDIÇÃO for FALSA) os COMANDOS DA CONDIÇÃO FALSA serão executados.

Sintaxe:

se <condição> entao

   <comandos da condição verdadeira>

senao

   <comandos da condição falsa>

fimse

Para facilitar o entendimento, vamos pensar naquela situação do cartão de crédito que vimos no post anterior:

se <sua esposa pegar seu cartão de crédito> entao

   <compras, compras, compras, compras...>

senao

   <fica na vontade>

fimse

Entendeu né? Vamos ao exemplo!

algoritmo "Desvio condicional composto"
// Função: Demonstrar a utilização do desvio condicional composto.
// Autor: Andrey Smith
// Data: 18/05/2014
// Seção de Declarações

var
nome: caractere
nota1, nota2, media: real

inicio
// Seção de Comandos

escreva ("Informe o nome do aluno: ")
leia (nome)
escreva ("Informe a nota da P1: ")
leia (nota1)
escreva ("Informe a nota da P2: ")
leia (nota2)

media <- (nota1 + nota2) / 2

se ( media >= 7) entao
   escreval ("A média do aluno ", nome, " é:", media)
senao
   escreval ("O aluno ", nome, " não alcançou a média.")
fimse

fimalgoritmo

Resultado do algoritmo com a CONDIÇÃO VERDADEIRA:

Resultado_desvio_condicional_composto_01

Resultado do algoritmo com a CONDIÇÃO FALSA:

Resultado_desvio_condicional_composto_01.1

Conclusão

O desvio de concional composto amplia as possibilidades do desvio condicional simples que vimos no post anterior. No próximo post veremos desvio condicional encadeado (SE… ENTÃO… SENÃO… SE… ENTÃO… SENÃO) que ampliara ainda mais nosso poder de fogo nos algoritmos. =)

Até o próximo!

:wq!
Andrey Smith

comentários
  1. ANTHTH disse:

    +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+ +_+

    Curtir

  2. Boa tarte Andrey, estou tentando fazer um exemplo simples apenas com as respostas S/N mas não estou conseguindo. Poderia me ajudar por favor?

    Aqui o código que estou usando:
    ———————————————————–
    algoritmo “Andança”
    var
    Resp: Logico

    inicio
    Escreva(“Posso andar? [S/N] “)
    Leia(Resp)
    Se (Resp) = Verdadeiro entao
    Escreva(“Andei. “)
    senao
    Escreva(“Vou ficar aqui. “)
    FimSe
    fimalgoritmo

    —————————————————————-

    Curtir

  3. R.Caroliny disse:

    Josimar, se você escolheu a variável (Resp: logico) você terá que pedir pro usuário digitar “verdadeiro ou falso”.

    Como você pediu pra ele digitar [s/n], você terá que colocar a variável (Resp) como caracter e no se Resp = “s”.

    Dessa forma:

    algoritmo “andança”
    var
    Resp: caracter

    inicio
    Escreva(“Posso andar? [S/N] “)
    Leia(Resp)
    Se (Resp = “s”) entao
    Escreva(“Andei. “)
    senao
    Escreva(“Vou ficar aqui. “)
    FimSe
    fimalgoritmo

    Espero ter ajudado!
    Até mais.

    Curtir

  4. Funcionou, nas aulas que eu assisti mostravam o exemplo da sintaxe apenas com variáveis reais ou inteiras.

    Muito obrigado!

    Curtir

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s