VisuALG #5 – Desvio condicional composto (SE… ENTÃO… SENÃO… FIMSE)

Publicado: maio 18, 2014 em Introdução à Ciência da Computação
Tags:, ,

VisuALG

SE… ENTÃO… SENÃO… FIMSE

O desvio condicional composto (SE… ENTÃO… SENÃO… FIMSE) funciona exatamente como o desvio condicional simples (SE… ENTÃO… FIMSE), com apenas uma diferença. No desvio condicional simples, somente podemos executar comandos SE a CONDIÇÃO for VERDADEIRA.

No desvio condicional composto, os comandos sempre serão executados independente da CONDIÇÃO, ou seja, SE a CONDIÇÃO for VERDADEIRA os COMANDOS DA CONDIÇÃO VERDADEIRA serão executados, SENÃO (SE a CONDIÇÃO for FALSA) os COMANDOS DA CONDIÇÃO FALSA serão executados.

Sintaxe:

se <condição> entao

   <comandos da condição verdadeira>

senao

   <comandos da condição falsa>

fimse

Para facilitar o entendimento, vamos pensar naquela situação do cartão de crédito que vimos no post anterior:

se <sua esposa pegar seu cartão de crédito> entao

   <compras, compras, compras, compras...>

senao

   <fica na vontade>

fimse

Entendeu né? Vamos ao exemplo!

algoritmo "Desvio condicional composto"
// Função: Demonstrar a utilização do desvio condicional composto.
// Autor: Andrey Smith
// Data: 18/05/2014
// Seção de Declarações

var
nome: caractere
nota1, nota2, media: real

inicio
// Seção de Comandos

escreva ("Informe o nome do aluno: ")
leia (nome)
escreva ("Informe a nota da P1: ")
leia (nota1)
escreva ("Informe a nota da P2: ")
leia (nota2)

media <- (nota1 + nota2) / 2

se ( media >= 7) entao
   escreval ("A média do aluno ", nome, " é:", media)
senao
   escreval ("O aluno ", nome, " não alcançou a média.")
fimse

fimalgoritmo

Resultado do algoritmo com a CONDIÇÃO VERDADEIRA:

Resultado_desvio_condicional_composto_01

Resultado do algoritmo com a CONDIÇÃO FALSA:

Resultado_desvio_condicional_composto_01.1

Conclusão

O desvio de concional composto amplia as possibilidades do desvio condicional simples que vimos no post anterior. No próximo post veremos desvio condicional encadeado (SE… ENTÃO… SENÃO… SE… ENTÃO… SENÃO) que ampliara ainda mais nosso poder de fogo nos algoritmos. =)

Até o próximo!

:wq!
Andrey Smith

Anúncios
comentários
  1. João Victor Ramires disse:

    Boa noite. Estou tendo problema com a condicional composta. Acredito ser erro de sintaxe.
    Veja bem, eu possuo duas variáveis que são incrementadas caso uma série de condições sejam atendidas, as variáveis são castanho e loira.
    Quando vou dar a saída de dados, faço um teste para saber se essas variáveis possuem valor maior que 0, caso não tenham uma mensagem é exibida.
    Caso não tenha, existe outra estrutura condicional para saber qual das variáveis ou as duas possuem a especificação e, o programa, imprime mensagens de acordo.
    No entanto, mesmo quando minha condição é atendida, o programa já está entrando no caso quando as condições não são cumpridas.
    Veja o código:

    se ((castanho=0) ou (loira=0)) entao
    escreval(“Não existe nenhuma pessoa com as especificações procuradas”)
    senao se (castanho>0) entao
    escreval (“Existem “,castanho,” homens maiores de 18 anos com cabelos castanhos.”)
    senao se (loira>0) entao
    escreval (“Existem “,loira,” mulheres entre 25 e 30 anos com cabelos loiros.”)
    fimse

    Curtir

  2. João Victor Ramires disse:

    Agora que me dei conta o erro semântico. HAHA Usei o operador lógico OU no lugar errado.

    Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

w

Conectando a %s