VisuALG #4 – Desvio condicional simples (SE… ENTÃO… FIMSE)

Publicado: maio 18, 2014 em Introdução à Ciência da Computação
Tags:, ,

VisuALG

SE… ENTÃO… FIMSE

O desvio condicional simples tem por finalidade executar uma ou mais instruções SE uma CONDIÇÃO for VERDADEIRA, ou seja, SE uma CONDIÇÃO for SATISFEITA. Uma CONDIÇÃO é uma comparação que possui dois valores possíveis: VERDADEIRO ou FALSO.

Ao encontrar este comando, o VisuALG analisa a CONDIÇÃO, SE o seu resultado for VERDADEIRO, todos os comandos da SEQUÊNCIA DE COMANDOS são executados. SE o resultado for FALSO, os comandos da SEQUÊNCIA DE COMANDOS são desprezados e a execução do algoritmo continua a partir da primeira linha depois do comando FIMSE.

Sintaxe:

se <condição> entao

   <sequência de comandos>

fimse

Para facilitar o entendimento, vamos pensar na seguinte situação:

se <sua esposa pegar seu cartão de crédito> entao

   <compras, compras, compras, compras...>

fimse

Entendeu? Vamos ao exemplo!

algoritmo "Desvio condicional simples"
// Função: Demonstrar a utilização do desvio condicional simples.
// Autor: Andrey Smith
// Data: 17/05/2014
// Seção de Declarações

var
nome: caractere
nota1, nota2, media: real

inicio
// Seção de Comandos

escreva ("Informe o nome do aluno: ")
leia (nome)
escreva ("Informe a nota da P1: ")
leia (nota1)
escreva ("Informe a nota da P2: ")
leia (nota2)

media <- (nota1 + nota2) / 2

se ( media >= 7) entao
   escreval ("A média do aluno ", nome, " é:", media)
fimse

escreval ("O aluno ", nome, " precisa comparecer na coordenação do curso.")

fimalgoritmo

Resultado do algoritmo com a CONDIÇÃO VERDADEIRA:

Resultado_desvio_condicional_simples_01

Resultado do algoritmo com a CONDIÇÃO FALSA:

Resultado_desvio_condicional_simples_01.1

Observe que, como dito anteriormente, pelo fato do resultado ser FALSO, a SEQUÊNCIA DE COMANDOS foi desprezada e a execução do algoritmo continuo a partir da primeira linha depois do fimse.

Conclusão

Nunca deixe sua esposa (Noiva, namorada, filha, etc) pegar seu cartão de crédito, pois esta é uma CONDIÇÃO que, SE  SATISFEITA, pode trazer alguns problemas. =)

Até o próximo!

:wq!
Andrey Smith

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s